It is currently Fri Apr 18, 2014 8:31 am

All times are UTC - 8 hours




Post new topic Reply to topic  [ 10 posts ] 
Author Message
 Post subject: PWM fan stuck at max speed, ignores speedfan settings
PostPosted: Mon Oct 07, 2013 2:56 pm 
Offline
Friend of SPCR

Joined: Sun May 06, 2007 10:37 am
Posts: 279
Has anyone encountered this problem? I'm not sure what's wrong with my system. It's an old file server running an MSI G41M-E43. I have a Slip Stream PWM fan plugged into the pwm fan header, but the fan just runs at max speed regardless of what settings I have in speedfan. I've disabled all forms of automatic fan control (motherboard and speedfan) that I'm aware of and tried adjusting the fan speed in speedfan manually. No dice. The fan just spins along at max speed even if I try to manually turn down the fan to like 0%. Quite frustrating.


Top
 Profile  
 
 Post subject: Re: PWM fan stuck at max speed, ignores speedfan settings
PostPosted: Tue Oct 08, 2013 12:20 am 
Offline

Joined: Fri Dec 26, 2003 6:54 am
Posts: 3003
Location: Sweden
Have you configured Speedfan to control the specific fan with PWM?

Readings > Configure > Advanced > Chip: Choose fan controller and check the settings. (No, I don't know what all the settings are for. ;) )

It could also be a 4-pin fan header that doesn't support PWM, although I doubt that since it's the CPU fan header.

Are you sure that PWM works at all? You didn't say if BIOS control worked.


Last edited by Mats on Tue Oct 08, 2013 12:28 am, edited 1 time in total.

Top
 Profile  
 
 Post subject: Re: PWM fan stuck at max speed, ignores speedfan settings
PostPosted: Tue Oct 08, 2013 12:28 am 
Offline

Joined: Fri Aug 05, 2005 3:29 am
Posts: 1067
Location: UK
Does the fan control section in MSI's OverClocking Center utility work?


Top
 Profile  
 
 Post subject: Re: PWM fan stuck at max speed, ignores speedfan settings
PostPosted: Wed Oct 09, 2013 5:40 pm 
Offline

Joined: Sun Oct 09, 2005 8:35 am
Posts: 1252
Location: Pleasanton, CA
This might not apply to your MB, but the last few boards I've had, it was necessary to first configure the BIOS to manual or disable, and then in SpeedFan, go to configure, advanced and then select the controller chip (Nuovotron on my current board), then select PWM manual. Then you can configure speeds. YMMV.

_________________
i7 2600K CPU@4.4 GHz, Asrock Z68, 8GB Corsair Vengeance 1866 CL9, Intel 335 240GB SSD + Samsung HD502HI 500GB, Internal i7 graphics, Antec P180 case, Seasonic X-400 fanless PS, Megahalems CPU HS, Nexus 3-pin & AC PWM fans ~ 600 RPM, AcoustiPack foam, homemade ducts.


Top
 Profile  
 
 Post subject: Re: PWM fan stuck at max speed, ignores speedfan settings
PostPosted: Wed Oct 09, 2013 5:46 pm 
Offline

Joined: Tue Nov 02, 2004 12:22 pm
Posts: 1564
Location: Guatemala
Are you using CPU_FAN1 header ?

Image

_________________
DESKTOP >> MSI Z87-GD65 | Intel Core i7-4770K | Thermalright HR-22 + TY150 @550rpm | Crucial Ballistix Sport 32GB DDR3 1600 | nVidia GTX780 + ARCTIC Accelero Xtreme III | Samsung SA850 27'' 2560x1440 | Samsung 840pro 512GB | Hitachi 7K1000 1TB | Fractal Design Define R4 + 4x Noctua NF-A14 PWM @225rpm | SeaSonic X-660
Other builds -->> Server | HTPC | Download Station


Top
 Profile  
 
 Post subject: Re: PWM fan stuck at max speed, ignores speedfan settings
PostPosted: Tue Oct 15, 2013 3:11 pm 
Offline
Friend of SPCR

Joined: Sun May 06, 2007 10:37 am
Posts: 279
Sorry guys, got busy for the past week.

Mats: Yeah, I've checked the speedfan settings and as far as I know I've set everything to what it should be. I have another PC that has speedfan controlling the fan properly.

lodestar: Haven't tried MSI overclocking software. Not even sure if it's compatible with this old board.

cmthomson: I've tried with both the BIOS enabled and disabled, and I don't see any difference.

Abula: It's the only 4-pin header on the board, so I'm assuming it's the right one.

It's not listed under speedfan's compatible boards list, so it just may be incompatible.


Top
 Profile  
 
 Post subject: Re: PWM fan stuck at max speed, ignores speedfan settings
PostPosted: Wed Oct 16, 2013 12:18 am 
Offline

Joined: Wed Jun 13, 2007 10:12 am
Posts: 2460
Location: ITALY
PartEleven wrote:
It's not listed under speedfan's compatible boards list, so it just may be incompatible.

I don't think so: but at any rate, more probably that not some screenshots of speedfan settings, and at least a phoneshot of the relevant bios screen would help more than one thousand posts, if you mind.

_________________
Regards,
Luca


Top
 Profile  
 
 Post subject: Re: PWM fan stuck at max speed, ignores speedfan settings
PostPosted: Wed Oct 16, 2013 1:07 pm 
Offline

Joined: Fri Aug 05, 2005 3:29 am
Posts: 1067
Location: UK
PartEleven wrote:
...Haven't tried MSI overclocking software. Not even sure if it's compatible with this old board...

The MSI OverClocking Center/Control Center software is listed under Download->Utility on the MSI web page for this board so it ought to work. I suggested it because if the manufacturer's fan control utility works then it shows that the motherboard is at least working as designed.

I also note from this screenshot from the Tom's Hardware site that the CPU fan can be set to run at 100% and this seems to tie in with what you are experiencing (but there does at least seem to be a Silent option which may help) :

Image


Top
 Profile  
 
 Post subject: Re: PWM fan stuck at max speed, ignores speedfan settings
PostPosted: Thu Oct 24, 2013 7:28 pm 
Offline
Friend of SPCR

Joined: Sun May 06, 2007 10:37 am
Posts: 279
So the problem seems to have fixed itself, and the fan now responds to speedfan settings. I'm a bit at a loss, since all I really did was change the PWM mode in Advanced to "temperature", then back to "manual". It has been on manual this whole time. Initially this didn't do anything, but a few days later the fan started responding to speed settings. I'm at a total loss why this happened.

On a side note, does anyone know exactly how speedfan controls fan speeds? I was under the impression that it works off the DESIRED and WARNING temperatures you set by increasing the fan speed gradually from min to max based on how high your component temperature is. I did some quick testing though, and at least on this system this is NOT how it works. Apparently it works like a simple on/off switch. My fan speed stays at MIN until my temperature hits the WARNING temperature, where the fan speed then shoots up to MAX. The fan stays at MAX speed until the temperature reading settles down below the DESIRED temperature. So instead of having a range of speeds, my fan essentially has two speeds: min and max. Is this how it's supposed to work?


Top
 Profile  
 
 Post subject: Re: PWM fan stuck at max speed, ignores speedfan settings
PostPosted: Fri Oct 25, 2013 5:02 am 
Offline

Joined: Sat Apr 30, 2005 4:29 pm
Posts: 106
There are 3 speeds.

1. Minimum value.
2. Desired temp gets reached ---> Maximum value
3. Warning temp gets reached ---> 100%


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 

All times are UTC - 8 hours


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group