VIA VT8237/VT8237R/VT6420/VT6421L SATA II incompatibility

Silencing hard drives, optical drives and other storage devices

Moderators: NeilBlanchard, Ralf Hutter, sthayashi, Lawrence Lee

Post Reply
Posts: 47
Joined: Tue Nov 25, 2003 10:24 am

VIA VT8237/VT8237R/VT6420/VT6421L SATA II incompatibility

Post by akerr63 » Tue Dec 06, 2005 10:27 am

While researching external drive enclosures I discovered this issue. A real pain for the future as all my PCs have VT8237 chipsets in them, but currently have IDE drives for other reasons (Acronis True Image support).

Apparently VIA chipsets VT8237, VT8237R, VT6420 and VT6421L are incompatible with SATA II (3 Gb/s, SATA-300) hard drives. If connected a SATA II drive won't be detected. From what I read the problem appears to be related to the SATA speed auto negotiation. Most hard drive manufacturers are now shipping SATA II drives. However some SATA II drives ship in SATA I mode, and other SATA II drives that ship with auto-negotiation might be able to be locked to operate at SATA I (via jumper or software setting in another PC without an incompatible VIA chipset!). I'm not clear if this means that every SATA II drive can be made to work with these Via chipsets.

Via are creating a new VT8237R Plus southbridge that corrects this problem, so motherboards with this new chipset should be ok. But this does not help current motherboard owners unless the drive can be locked to SATA I.

Can anyone comment on using new SATA II drives with a VT8237?? I'm assuming all the recent large capacity drives are SATA II but have not checked yet.

Posts: 28
Joined: Fri Nov 04, 2005 1:50 am
Location: Germany

Post by flokel » Thu Dec 08, 2005 2:20 am


i'm currently using a seagate sataII drive with my asus a8v (VT8237),
the promise sata controller detects it whilst the onboard one needs the drive to be set to sataI via jumper.

Posts: 87
Joined: Mon Nov 14, 2005 8:03 am
Location: Budapest, Hungary

Post by Charles » Thu Dec 08, 2005 3:16 pm

Yup, same by me. With an Abit Av8 + Samsung Sata2 drive.

Promise detects my Sata1 and Sata2 Samsung, but the V8237 not. Had to set the Sata2 Samsung's Jumper to Sata1 compatibity mode...

The manual of the Samsung HDD mentions this issue...


Posts: 21
Joined: Thu Jan 08, 2004 6:36 am

Not just a VIA issue

Post by Arcanthis » Sat Dec 17, 2005 6:14 am

I recently purchased a Samsung 120 GB SATA II drive (HD120IJ) and tried installing it on an Asus A8N-SLI Premium (nforce 4) as the system drive. I repeatedly had issues, during the install process I would get a hard crash at random points or if I managed to get windows to boot up I would then get random blue screens.

Tried low level testing and formatting using Samsungs tool (hutil) and everything checked out fine, but still I could not get a good install of Windows. I finally decided to try setting the jumper on the drive to force SATA I and have not had another issue.

Now, I also have a Western Digital WD1200JS which is also SATA II and have been using that fine as a system drive on this same motherboard, the only difference is it doesn't have NCQ which the Samsung does. Yet, once again I have a Maxtor with NCQ on the same system which appears ok (not a system drive).

Searching the net it appears there are various incompatibilities with SATA II and certain motherboards/chipsets being experienced by many people, so it's not only VIA with problems. Pretty frustrating since I had not previously had issues with the other two drives.

Posts: 47
Joined: Tue Nov 25, 2003 10:24 am

Post by akerr63 » Sat Dec 17, 2005 8:13 am

This Western Digital support page "Problems are encountered when installing Second Generation Serial ATA hard drives on First Generation Serial ATA controllers" lists a similar auto-negotiation issue with SIS760 and SIS964 chipsets.

Post Reply