Force a PWM CPU fan to run at full speed?

Cooling Processors quietly

Moderators: NeilBlanchard, Ralf Hutter, sthayashi, Lawrence Lee

Post Reply
rhardy
Posts: 8
Joined: Sun Sep 04, 2016 8:16 am

Force a PWM CPU fan to run at full speed?

Post by rhardy » Sun Sep 04, 2016 8:36 am

I have an Asus P6T Deluxe V2 with an Intel i7 920 CPU. Unfortunately this motherboard is quite braindead if you aren't running Windows. In theory it controls the CPU fan using PWM.
Instead of running the fan on auto or at full speed before Windows loads the board runs it at a low idle speed. Great for noise not so good if you want the CPU not to crash when it gets hot. Asus has been truely useless at helping fix this. The BIOS gives almost no control of the CPU fan. I also can't really swap out the heatsink and fan because the board design depends on the stock air flow to cool the rest of the chips (which get hot easily.) I realize this is opposite of what most want on here but you guys know cooling and fans. Anyone have a suggestion on how I might work around this issue?
I'm hoping I can just install a short extension cable between the CPU fan and CPUFAN header, cut one of the wires and have it always run full speed.

Fire-Flare
Posts: 422
Joined: Sun Jun 13, 2010 12:44 pm
Location: Seattle

Re: Force a PWM CPU fan to run at full speed?

Post by Fire-Flare » Tue Sep 06, 2016 1:33 pm

There are fan power adapters that allow the fan to run at a constant 12v while passing the RPM signal to a header on the motherboard.

I found one on Ebay here: http://www.ebay.com/itm/3-pin-to-4-pin- ... 1984200952
My build: viewtopic.php?f=14&t=69018

Swiftech MCP35X review: viewtopic.php?f=27&t=65287

SebRad
Patron of SPCR
Posts: 1121
Joined: Sun Nov 09, 2003 7:18 am
Location: UK

Re: Force a PWM CPU fan to run at full speed?

Post by SebRad » Wed Sep 07, 2016 12:22 am

Hi, if you simply remove the 4th, PWM control wire from the fan plug the fan will run at full speed.
It's usually green or blue coloured, with the aid of a pin or thin blade you can press the tab in the back of the plug that holds the wire in and just pull it out. If you manage this you then easily just push it back in if you ever needed to reverse the mod.

See my posts at bottom of this thread: viewtopic.php?t=37909

Seb
i7 2600k under NH-C14 w/2xTY-147PWM fans, P8P67Deluxe, 8GB RAM, GTX560Ti OC w/TwinTurbo II and BIOS fanspeed mod. MX100 512GB & 2TB EARX in Scythe QuietDrive outside case. Antec Signature 650 fan swapped. CoolerMaster 201C with 2x92 + lower 92mm fan out rear, holes-in-floor and mesh top+front intakes.

quest_for_silence
Posts: 5275
Joined: Wed Jun 13, 2007 10:12 am
Location: ITALY

Re: Force a PWM CPU fan to run at full speed?

Post by quest_for_silence » Wed Sep 07, 2016 12:47 am

rhardy wrote:I also can't really swap out the heatsink and fan because the board design depends on the stock air flow to cool the rest of the chips (which get hot easily.)

You don't need the stock cooler, you just need a better top down cooler (the stock being rather underwhelming).

BTW the BIOS settings should offer those usual 8 years old fan controls.
Regards,
Luca

Support SPCR, use these links when you buy: NCIX, Amazon and Newegg

lodestar
Posts: 1683
Joined: Fri Aug 05, 2005 3:29 am
Location: UK

Re: Force a PWM CPU fan to run at full speed?

Post by lodestar » Wed Sep 07, 2016 3:22 am

A popular cooler for these CPUs at the time was the Noctua NH-C14, partly because it came with the LGA1366 fittings required. And partly because it offered some direct cooling of the motherboard components in a similar way to the stock device. Although now discontinued it does turn up on eBay fairly frequently, if you can get one complete at the right price it would be a vast improvement on the stock cooler. It was tested by SPCR. The only drawback is that it used 3 pin fans, not PWM. The fan clips fit any 120mm fan so a PWM replacement is feasible. Some of my gamer family members had X58 systems during the 2008/9 period, and they used the Noctua NH-C14 with just one 120mm PWM fan on the top and found it perfectly OK. The contemporary PWM fan of choice was the Akasa Apache which had a 600 to 1600 speed spec, but typically would idle using the Asus BIOS Silent Profile in the 550 rpm range.

rhardy
Posts: 8
Joined: Sun Sep 04, 2016 8:16 am

Re: Force a PWM CPU fan to run at full speed?

Post by rhardy » Thu Sep 08, 2016 1:50 pm

SebRad wrote:Hi, if you simply remove the 4th, PWM control wire from the fan plug the fan will run at full speed. It's usually green or blue coloured...
I was really hopeful this was this simple but it doesn't seem to be. I took my 4 pin CPU fan and put on my three pin chassis 2 fan header being careful to ensure it was the blue wire. End result is a CPU fan still running at it's idle 900 rpms i.e. not the 1800-2000 rpms it reaches at full speed.

Re: the Noctua NH-C14 might work but it seems a shame to waste $100 on a new heatsink just to get a fan to run at full speed.

Fire-Flare
Posts: 422
Joined: Sun Jun 13, 2010 12:44 pm
Location: Seattle

Re: Force a PWM CPU fan to run at full speed?

Post by Fire-Flare » Thu Sep 08, 2016 3:08 pm

rhardy wrote:
SebRad wrote:Hi, if you simply remove the 4th, PWM control wire from the fan plug the fan will run at full speed. It's usually green or blue coloured...
I was really hopeful this was this simple but it doesn't seem to be. I took my 4 pin CPU fan and put on my three pin chassis 2 fan header being careful to ensure it was the blue wire. End result is a CPU fan still running at it's idle 900 rpms i.e. not the 1800-2000 rpms it reaches at full speed.
Sounds like it's being voltage controlled rather than PWM.

The power adapter I mentioned is much cheaper than a new cooler and will allow your motherboard to still read the RPM of the fan.
My build: viewtopic.php?f=14&t=69018

Swiftech MCP35X review: viewtopic.php?f=27&t=65287

lodestar
Posts: 1683
Joined: Fri Aug 05, 2005 3:29 am
Location: UK

Re: Force a PWM CPU fan to run at full speed?

Post by lodestar » Thu Sep 08, 2016 3:52 pm

rhardy wrote:I took my 4 pin CPU fan and put on my three pin chassis 2 fan header being careful to ensure it was the blue wire. End result is a CPU fan still running at it's idle 900 rpms i.e. not the 1800-2000 rpms it reaches at full speed.
From what I remember of these boards there was a header marked PWR_FAN. This was a 3 pin header designed as its name suggests to monitor the speed of a power supply fan (there were PSUs around at the time which had an external lead which you could plug into this header). However in addition the PWR_FAN header also supplied an uncontrolled 12V so any fan plugged into it, 3 pin or otherwise, would run at full speed and its rpm could be monitored. So try plugging the CPU PWM fan into this header and you should get the desired result.

rhardy
Posts: 8
Joined: Sun Sep 04, 2016 8:16 am

Re: Force a PWM CPU fan to run at full speed?

Post by rhardy » Thu Sep 08, 2016 8:50 pm

lodestar wrote:From what I remember of these boards there was a header marked PWR_FAN. This was a 3 pin header designed as its name suggests to monitor the speed of a power supply fan (there were PSUs around at the time which had an external lead which you could plug into this header). However in addition the PWR_FAN header also supplied an uncontrolled 12V so any fan plugged into it, 3 pin or otherwise, would run at full speed and its rpm could be monitored. So try plugging the CPU PWM fan into this header and you should get the desired result.
I hoped this would finally do it but this didn't get the CPU fan to full speed either. When connected to PWN_FAN the CPU fan rpms were in same i.e. not full speed. They ran at ~900 rpms.
I suspect the fan leads are getting the full voltage but the fan only speeds up if it gets the right PWM signal. This also means the adapter cable will do the exact same thing. What a pain...
I wonder if I can find a really simple PWM fan controller to run the cpu fan at full speed...
Last edited by rhardy on Thu Sep 08, 2016 8:55 pm, edited 1 time in total.

quest_for_silence
Posts: 5275
Joined: Wed Jun 13, 2007 10:12 am
Location: ITALY

Re: Force a PWM CPU fan to run at full speed?

Post by quest_for_silence » Thu Sep 08, 2016 8:52 pm

rhardy wrote:just to get a fan to run at full speed.

Are you saying that either disabling CPU Q-Fan Control, or setting it to "Turbo", doesn't change at all the stock cooler fan speed?

BTW, somehow it sounds rather odd that you ask here how to make your rig as loud as possible.
Regards,
Luca

Support SPCR, use these links when you buy: NCIX, Amazon and Newegg

rhardy
Posts: 8
Joined: Sun Sep 04, 2016 8:16 am

Re: Force a PWM CPU fan to run at full speed?

Post by rhardy » Thu Sep 08, 2016 9:11 pm

quest_for_silence wrote:Are you saying that either disabling CPU Q-Fan Control, or setting it to "Turbo", doesn't change at all the stock cooler fan speed?

BTW, somehow it sounds rather odd that you ask here how to make your rig as loud as possible.
I am saying on this board changing to Turbo does nothing unless you are running Windows.

Unfortunately the BIOS controls are extremely primitive on this board. It also seems Asus BIOS Q-Fan controls only work as they should if you are running Windows and then only after Windows takes control. I am not running Windows and the default BIOS behaviour sucks.
Yes I realize this is backwards to what a lot of people want on here but the reason is quite simple.
The hardware gives me two options:
  • a. a quiet low speed CPU fan that over heats.
    b. a full speed CPU fan that never over heats.
For a small server I definite need b. i.e. a CPU that doesn't overheat.

Vicotnik
*Lifetime Patron*
Posts: 1818
Joined: Thu Feb 13, 2003 6:53 am
Location: Sweden

Re: Force a PWM CPU fan to run at full speed?

Post by Vicotnik » Thu Sep 08, 2016 11:01 pm

If you have a multimeter you could measure the voltage that the motherboard feeds to the fan. That would tell you if the fan itself slows down even if it receives 12V.

The Q-Fan controls should be OS independent. Maybe try update the BIOS unless you are already running the latest version.
Main: ASRock B85M-ITX | i3-4330 | 16GB DDR3 | Intel 730 240GB | HDPLEX H1-S | picoPSU | No moving parts | Idle 13.9W
HTPC: ASRock H81M-ITX | Pentium G3420 | 4GB DDR3 | Intel 535 120GB | HDPLEX H1-S | picoPSU | No moving parts | Idle 11.2W
Gaming: Intel DH77EB | i5-3570K | GTX 1060 6GB | 16GB DDR3 | TJ08-E | RM750X
Server: ASRock N3150-ITX | ~30TB | G-360 | Idle ~25W

lodestar
Posts: 1683
Joined: Fri Aug 05, 2005 3:29 am
Location: UK

Re: Force a PWM CPU fan to run at full speed?

Post by lodestar » Thu Sep 08, 2016 11:08 pm

rhardy wrote:When connected to PWN_FAN the CPU fan rpms were in same i.e. not full speed. They ran at ~900 rpms....
How PWM works is that a full 12V is supplied and the fourth cable carries a control signal that instructs the integrated circuit built into the fan to pulse this voltage to the motor. In the absence of the control signal this is bypassed and the full voltage passed to the fan which will run at full speed. So what you're seeing is the maximum the fan will do, which is below spec but may reflect that the fan itself is faulty. You could try one of the cables that connect a fan direct to the PSU but if the fan is faulty the result will be just the same. I think you need to replace the cooler. A compatible blow down type cooler is not going to be that expensive and will definitely end your overheating issues. This one for example costs $37 from Newegg.

quest_for_silence
Posts: 5275
Joined: Wed Jun 13, 2007 10:12 am
Location: ITALY

Re: Force a PWM CPU fan to run at full speed?

Post by quest_for_silence » Fri Sep 09, 2016 1:26 am

rhardy wrote:I am saying on this board changing to Turbo does nothing unless you are running Windows.

That should be not possible.

BIOS controls are OS-independent by definition: so the reason behind your issue should not be that one (providing there is an issue, actually).

rhardy wrote:The hardware gives me two options:
  • a. a quiet low speed CPU fan that over heats.
    b. a full speed CPU fan that never over heats.
For a small server I definite need b. i.e. a CPU that doesn't overheat.

If you don't want to take any potential risk with the current setup, I guess you don't have to hack anything, but just disable the Q-Fan control: then the cooler should run @ full speed, and if that won't happen, your mobo is likely defective.

BTW, if the board doesn't dial the fan up with the "Turbo" option enabled, it does that because the CPU actually do not overheat. On the other hand, similarly to what said above, whether the CPU actually overheats with that "Turbo" option enabled, either the DTS or the motherboard is defective.

Providing both the board and the CPU DTS are not at fault, if you want to solve the overheating problem with a new cooler, on NewEgg you may look at this one: http://www.newegg.com/Product/Product.a ... 66Z28G9982
I guess it's the best performing top down cooler under 50$ on their catalogue (atm), and you may still strap a more powerful fan on it, if you wanted some more cooling prowess.

Obviously, there are other sources than NewEgg, and different, beefier coolers (albeit not for 29 bucks, I guess).
Regards,
Luca

Support SPCR, use these links when you buy: NCIX, Amazon and Newegg

SebRad
Patron of SPCR
Posts: 1121
Joined: Sun Nov 09, 2003 7:18 am
Location: UK

Re: Force a PWM CPU fan to run at full speed?

Post by SebRad » Fri Sep 09, 2016 11:59 am

Hi, as you have an older rig I presume you have molex plugs on your PSU. In which case you can remove the fan wires from the plug and, with a bit of fix-able squashing, you can shove the -ve (pin 1) in to a black wire and +ve (pin 2) in to yellow 12v wire. This is 100% definitely giving fan 12v, bypassing all motherboard control etc. You can leave speed signal (pin 3) in the plug and connected to the motherboard to monitor the speed. PWM (pin 4) if left disconnected should cause the fan to run at 100% speed, unless there is a problem with it.
I guess you are using stock intel cooler? You could probably cut the stock fan off and replace it with a standard 92mm one, zip ties work well for this sort of thing. Allowing you to get a different fan with whatever balance of speed/noise you want. If you need more cooling of the surrounding than the CPU you could even try a 120mm fan for more spill of air flow.

Good luck,
Seb
i7 2600k under NH-C14 w/2xTY-147PWM fans, P8P67Deluxe, 8GB RAM, GTX560Ti OC w/TwinTurbo II and BIOS fanspeed mod. MX100 512GB & 2TB EARX in Scythe QuietDrive outside case. Antec Signature 650 fan swapped. CoolerMaster 201C with 2x92 + lower 92mm fan out rear, holes-in-floor and mesh top+front intakes.

rhardy
Posts: 8
Joined: Sun Sep 04, 2016 8:16 am

Re: Force a PWM CPU fan to run at full speed?

Post by rhardy » Fri Sep 09, 2016 2:27 pm

lodestar wrote:
rhardy wrote:When connected to PWN_FAN the CPU fan rpms were in same i.e. not full speed. They ran at ~900 rpms....
How PWM works is that a full 12V is supplied and the fourth cable carries a control signal that instructs the integrated circuit built into the fan to pulse this voltage to the motor. In the absence of the control signal this is bypassed and the full voltage passed to the fan which will run at full speed. So what you're seeing is the maximum the fan will do, which is below spec but may reflect that the fan itself is faulty. You could try one of the cables that connect a fan direct to the PSU but if the fan is faulty the result will be just the same. I think you need to replace the cooler. A compatible blow down type cooler is not going to be that expensive and will definitely end your overheating issues. This one for example costs $37 from Newegg.
I agree Intel PWM fan specifications say "If no control signal is present the fan shall operate at maximum RPM." Unfortunately it isn't doing that.
There is no question the BIOS behaviour is broken too. I have the latest BIOS.
I either some how got two CPU fans with the same defect or it is just a quirk for this model of fan.
It does work once Windows is loaded. I have two of these boards and went through the slow process of swapping the heatsink and fan between them. I also booted the Windows system from a Linux live iso and it started failing the same way.
I've toggled all the bios options to little effect. I've tried three different fan headers on the motherboard.
The only explaination is this Stock Intel PWM CPU fan actually runs at low speed not full speed when it doesn't get a control signal.
I'm fairly sure at this point the fan is already getting full voltage. Actually measuring the voltage while the motherboard is powered on has been challenging to pull off. I really don't want to short out my raid controller. If the fault is in the fan design then replacing the heatsink and fan with one that actually follows the specification would hopefully work.
Last edited by rhardy on Sat Sep 10, 2016 12:08 pm, edited 1 time in total.

quest_for_silence
Posts: 5275
Joined: Wed Jun 13, 2007 10:12 am
Location: ITALY

Re: Force a PWM CPU fan to run at full speed?

Post by quest_for_silence » Fri Sep 09, 2016 9:11 pm

Just out of curiosity, how much high is the cpu temp alternatively reported in the BIOS, at Linux boot and at Windows logon?
Regards,
Luca

Support SPCR, use these links when you buy: NCIX, Amazon and Newegg

rhardy
Posts: 8
Joined: Sun Sep 04, 2016 8:16 am

Re: Force a PWM CPU fan to run at full speed?

Post by rhardy » Sat Sep 10, 2016 12:06 pm

I've replaced the thermal paste so cooling is quite good when the fans are working properly.
In Linux with an idle CPU I get CPU temperatures between 33C and 40C. The bios HW monitor shows similar temperatures.
In Windows in CPUID HWMonitor I get around 40C for CPUTIN.
The difference is under load. If I do a CPU stress test In Linux my temperature quickly rises when under load and my problems usually start once my temperature goes over 80C.
Under Windows the CPU fan simply speeds up and keeps things reasonable cool even when loaded. The CPUTIN usually stays below 50C.

quest_for_silence
Posts: 5275
Joined: Wed Jun 13, 2007 10:12 am
Location: ITALY

Linux fan control (Force a PWM CPU fan to run at full speed?

Post by quest_for_silence » Sat Sep 10, 2016 12:44 pm

rhardy wrote:The difference is under load. If I do a CPU stress test In Linux my temperature quickly rises when under load and my problems usually start once my temperature goes over 80C.
Frankly I guess you should have some misconfiguration under Linux: it looks like something (lm-sensors/pwmconfig?) kicks in and take control of your PWM header in the wrong way (fancontrol anyone?). Alternatively I should think that your current setup might not read the CPUTIN sensor that correctly.

Check that, because this issue will be the same with a beefier cooler: perhaps you may start a separate thread about fan control under linux, so that other linux-users might help you to eventually debug your current setup.
Regards,
Luca

Support SPCR, use these links when you buy: NCIX, Amazon and Newegg

rhardy
Posts: 8
Joined: Sun Sep 04, 2016 8:16 am

Re: Force a PWM CPU fan to run at full speed?

Post by rhardy » Sat Sep 10, 2016 3:11 pm

I'm an engineer with 20+ years of Linux experience. I tried the Linux fan support first. It was a dead end with this board. I've tried several drivers and even decompiled the DSDT to see if triggering some of the Windows specific things would make it work. It didn't. The autodetected driver exposes no PWM controls and w83627ehf driver only allowed me to slow/turn off one of the existing fans which isn't helpful. It is really sad when Intel writes the PWM fan specification and then doesn't follow it. I suspect due to the blast of noise it caused on reboot. If I get a replacement PWM HS + fan that actually follows the spec i.e. goes full speed when the control signal is disconnected I would be good. The problem being if Intel isn't following their own fan specification who will? It is going to be trial and error.

I did more digging and it seems that my stock Intel PWM CPU fan is one of the unfortunate fans that only goes full speed with a 5V signal applied to the blue control wire. Now if I could find an adapter cable for that I would be set too... Most I've found assume control disconnected is 100% fan speed.

rhardy
Posts: 8
Joined: Sun Sep 04, 2016 8:16 am

Re: Force a PWM CPU fan to run at full speed?

Post by rhardy » Sun Sep 25, 2016 12:36 pm

Just an FYI in case someone else runs into this. I ended up finding out this was a combination of a design flaw with the stock Intel cooler and ASUS poor Linux support.
In the end I found a 3rd party heatsink and fan which actually followed the PWM specifications i.e. with all the bios fan controls disabled it properly ran at full speed instead of low speed.
I'm calling this a design flaw because I tested two stock Intel coolers. Pretty sad given Intel wrote the specifications in the first place.... Thanks for all the assistance with this.

quest_for_silence
Posts: 5275
Joined: Wed Jun 13, 2007 10:12 am
Location: ITALY

Re: Force a PWM CPU fan to run at full speed?

Post by quest_for_silence » Sun Sep 25, 2016 9:08 pm

Thanks for sharing.
Regards,
Luca

Support SPCR, use these links when you buy: NCIX, Amazon and Newegg

Post Reply