How to properly mount Scythe Kotetsu fan clips? [Solved]

Cooling Processors quietly

Moderators: NeilBlanchard, Ralf Hutter, sthayashi, Lawrence Lee

Post Reply
yakuman
Posts: 140
Joined: Thu Jun 07, 2012 3:05 am
Location: Canada

How to properly mount Scythe Kotetsu fan clips? [Solved]

Post by yakuman » Mon Jan 29, 2018 4:24 pm

This may be trivial, but it looks like I didn't hook the clips correctly onto the heat sink. The top and bottom clips fit right into the ridges, but the Kotetsu fan isn't completely flushed against its own small ridges. I only managed to get it correct once by fluke. It must have come off loose during some disassembly and flipping of my case sideways. Rather than the fan clips clipping on to the fins, it feels like they're merely hanging on. While the fan works fine in terms of noise and temperatures, it's been bugging me that i's non-optimal during higher RPMs.

There are no clear instructions I could find. Scythe's YouTube tutorial on the Mugen 4 makes it look easy, which it probably is, but not for me. It's ironic that every single image I Googled including SPCR's review show the clips not exactly straight along the ridges, while mine are. Everyone else's clips slightly bend outwards at the centre, leaving me wonder how can they can keep them rigid. My definitely is not when I wiggle the fan around a bit. The only time it was stable was during that one fluke. Upon care examination of other images, the fins near the clip ends appear to be bending too, while all of fins are straight like they're untouched.

SPCR's images:ImageImage

My images:
Fan Clip Top.jpg
Fan Clip Bottom.jpg
What am I doing wrong?
You do not have the required permissions to view the files attached to this post.
Last edited by yakuman on Sun Feb 04, 2018 10:01 am, edited 1 time in total.

yakuman
Posts: 140
Joined: Thu Jun 07, 2012 3:05 am
Location: Canada

Re: How to properly mount Scythe Kotetsu fan clips?

Post by yakuman » Sun Feb 04, 2018 10:01 am

Answering my own question here (I've been doing that lately here in the forums :roll: ), but once again I experienced the fluke where this time only the bottom clip is secured into the heat sink's ridge. The top was still hanging loose. Upset, I tried lifting the top clip higher while holding the fan pressed flushed against the fins. The pointy edge of the clip that was pointing towards the back is now closer to pointing directly north. I still can't explain why this is as nothing changed on the fins. I'll considered this solved (hopefully).

CA_Steve
Moderator
Posts: 7449
Joined: Thu Oct 06, 2005 4:36 am
Location: St. Louis, MO

Re: How to properly mount Scythe Kotetsu fan clips? [Solved]

Post by CA_Steve » Sun Feb 04, 2018 4:07 pm

Sorry - I didn't have a simple "do this" answer. My experiences involved wrestling the clips into submission with a needle nose pliers after the bottoms were attached.
1080p Gaming build: i5-4670K, Mugen 4, Asrock Z97 Anniversary, MSI GTX 1660 Gaming X, 8GB 1866 RAM, Samsung 860 Evo 500GB, Crucial MX100 256GB, WD Red 2TB, Samsung DVD burner, Fractal Define R4, Antec True Quiet 140 (2 front + rear) case fans, Seasonic SSR-550FX. 35W idle, 45-55W video streaming, 170-200W WoW, 318W stress test (Prime95 + Furmark)

yakuman
Posts: 140
Joined: Thu Jun 07, 2012 3:05 am
Location: Canada

Re: How to properly mount Scythe Kotetsu fan clips? [Solved]

Post by yakuman » Sun Feb 04, 2018 5:56 pm

It was thanks to your advice about the pliers on an old thread that I was able to continue with the installation. That was actually the most frustrating part as I couldn't wrap my head around how to place the clips in the fan itself. No instructions :x. There's no reason why Scythe couldn't pre-bend them for users.

The most nerve racking part was adding thermal paste (I used my old Noctua one that came with my NH U14S) and then mounting it in centre - or rather the mental fear that I always had in my mind that gave the illusion that heat sinks are the most challenging of all the PC parts to assemble. I made an error as it wasn't centred, but then quickly caught on and slow dragged to the centre. Luckily there haven't been any temperature issues :)

CA_Steve
Moderator
Posts: 7449
Joined: Thu Oct 06, 2005 4:36 am
Location: St. Louis, MO

Re: How to properly mount Scythe Kotetsu fan clips? [Solved]

Post by CA_Steve » Mon Feb 05, 2018 7:18 am

I'd rather deal with cooler mounting any day over troubleshooting Windows OS issues :)
1080p Gaming build: i5-4670K, Mugen 4, Asrock Z97 Anniversary, MSI GTX 1660 Gaming X, 8GB 1866 RAM, Samsung 860 Evo 500GB, Crucial MX100 256GB, WD Red 2TB, Samsung DVD burner, Fractal Define R4, Antec True Quiet 140 (2 front + rear) case fans, Seasonic SSR-550FX. 35W idle, 45-55W video streaming, 170-200W WoW, 318W stress test (Prime95 + Furmark)

yakuman
Posts: 140
Joined: Thu Jun 07, 2012 3:05 am
Location: Canada

Re: How to properly mount Scythe Kotetsu fan clips? [Solved]

Post by yakuman » Mon Feb 05, 2018 8:51 am

Windows issues are long term and on-going, especially 10 with its constant updates.

Post Reply