I cannot get Asus Q-Fan to work

Cooling Processors quietly

Moderators: NeilBlanchard, Ralf Hutter, sthayashi, Lawrence Lee

Post Reply
Andersson
Posts: 9
Joined: Fri Aug 12, 2005 11:48 am

I cannot get Asus Q-Fan to work

Post by Andersson » Fri Dec 07, 2007 12:23 pm

I have enabled Q-Fan in BIOS, like you can see in the screen shot below. It still does not seem to do anything. I have tried other settings as well and of course saved the settings and restarted several times in the process.

As I understand it, if the CPU temp is lower than the target temperature, the fan will run at a slower speed based on the fan ratio. But no matter what settings I try, all I see is 45 degrees and 2600 rpm fan speed. What am I doing wrong?

Image

The mobo is an Asus P5B-MX micro-atx and the cpu a celeron 420 with a stock cooler. It might be hard to see on this pic, but the fan is connected to the right spot.

Image

Redzo
Posts: 464
Joined: Thu Jan 26, 2006 1:51 am
Location: Sweden, Stockholm

Post by Redzo » Fri Dec 07, 2007 1:23 pm

You are probably not doing anything wrong, instead most likely Qfan is broken. It happens to Asus once in a while. Tried another bios ! Couse thats what i would do.

Andersson
Posts: 9
Joined: Fri Aug 12, 2005 11:48 am

Post by Andersson » Sat Dec 08, 2007 1:28 pm

Thanks for the tip. I updated to the newest bios -version 0506 I think- but it still doesn't work. Something is weird though, the version number in the menu is still the same as in the screen shot above, v2.58. But the first bios screen says version 0506. Perhaps there's more than one program involved?

Anyway, I guess I'll have to do without q-fan.

seraphyn
Posts: 322
Joined: Wed Nov 28, 2007 1:26 pm
Location: Netherlands

Post by seraphyn » Sat Dec 08, 2007 1:34 pm

Tried enabling chassis fan speed? Perhaps there is a hidden chassis temperature setting which is being met and thus it wont tone down.

In any case, I'm not a big fan of Asus Q-fan. Hasn't really worked for me on my Asus P5K Premium, which made me use a normal fancontroller.

dhanson865
Posts: 2198
Joined: Thu Feb 10, 2005 11:20 am
Location: TN, USA

Post by dhanson865 » Sat Dec 08, 2007 2:49 pm

If you expect it to lower your fan speed much you need to move the CPU target temperature up. I set it to the maximum (something like 80c but I don't remember the exact number).

qFan is very conservative. You have to give it an unrealistic target temp for it to do much good.
.
Please put a country in your profile if you haven't already.
This site is international but I'll assume you are in the US if you don't tell me otherwise.
RAID levels thread http://www.silentpcreview.com/forums/viewtopic.php?p=388987

sjoukew
Posts: 401
Joined: Mon Nov 27, 2006 6:51 am
Location: The Netherlands (NL)
Contact:

Post by sjoukew » Sun Dec 09, 2007 5:28 am

I do have the asus p5w-dh deluxe. That Q-Fan works, but all it does is lowering the fan rpm to a predefined setting high, medium or low. It is NOT adaptive. The old asus q-fan's were adaptive. The newer versions are not, at least that is what I have read on the asus website. I didn't like it, but that is how it is :(; at least with my motherboard.

Andersson
Posts: 9
Joined: Fri Aug 12, 2005 11:48 am

Post by Andersson » Sun Dec 09, 2007 7:10 pm

I removed the motherboard temporarily, to remove the hd rack. When I get it back together I'll try to enable the chassis fan. Since I'll replace the antec case fan (with a 4-pin molex) for a nexus, I'll actually have a 3-pin connector to plug in and get a reading from. Maybe that will help.

I did try with a number of settings, including the "maximum". I think that was 60 something degrees and a ratio of 20%. Although I only left the computer on for about 20 minutes, but I noticed no difference.

Oh, by the way, when is q-fan supposed to start working? Do I need to actually boot an os? Stupid question maybe, but maybe the bios setup is in some kind of fail safe mode with all the fans on max speed..?

sjoukew, does your setup menu look the same as mine, or is it another version?

CallMeJoe
Posts: 207
Joined: Wed Aug 27, 2003 11:01 am
Location: Secession State

Post by CallMeJoe » Sun Dec 09, 2007 8:00 pm

Q-Fan works on my P5N-E SLI, but I'm using a Sunbeam Silent Whisper CPU HS, which has a PWM controlled fan. Does Q-Fan need PWM on the Intel C2D boards? Does your heatsink fan have PWM (4-pin connector)?
[size=75]Patriotism means to stand by the country. It does not mean to stand by the President.
[i]Theodore Roosevelt[/i][/size]

PopCorn
Posts: 346
Joined: Tue Dec 12, 2006 5:09 pm
Location: U.S.A. Massuchusetts...... *Folding For SPCR*
Contact:

Post by PopCorn » Wed Dec 12, 2007 9:02 pm

yea i think all together the Q-fan sucks,, iv never been able to get it to work on my M2N SLI-Delux...... iv tried every thing
And with that being said I have always been a bit proud of my 1337 computer sk1llz

bp
Posts: 19
Joined: Tue Dec 04, 2007 1:55 am

Post by bp » Thu Dec 13, 2007 7:38 am

on my P5K-SE with Intel Core 2 cpu:

fan control of the processor works fine (between 800 - 880 rpm, never needed more than that). If I disable Qfan control, fan get much louder. I have different profiles that I can choose from: silent/perfomance/auto. No temperature.

fan control of the case: didn't work in the beginning (I couldn't monitor the current fan speed, speed was N/A rpm). In fact, my fan was so slow (< 600 rpm, noctua fan with ULNA resistor), that it couldn't measure it. without ULNA, I got 1200 rpm at first, but after setting Qfan to 'auto' and rebooting (needed reboot to apply the Qfan settings from the BIOS), the fan was regulated. Fan now runs between 800 and 1200 rpm. It can even be 600 with LNA resistor (smaller resistor than ULNA).

If plugging a fan into the PWR fan connector, I can monitor the speed, but I can't set any profile or dynamic behaviour into the BIOS, so it is fixed speed.

best regards.

PopCorn
Posts: 346
Joined: Tue Dec 12, 2006 5:09 pm
Location: U.S.A. Massuchusetts...... *Folding For SPCR*
Contact:

Post by PopCorn » Thu Dec 13, 2007 10:33 am

wow i figured id mess around with Qfan alittle more and right of the bat it was working, then agian iv also done a bios update since the last time iv tried it, so i take back about the part of it sucking
And with that being said I have always been a bit proud of my 1337 computer sk1llz

MoJo
Posts: 773
Joined: Mon Jan 13, 2003 9:20 am
Location: UK

Post by MoJo » Thu Dec 13, 2007 1:40 pm

I'm on the latest beta BIOS for my board (P5N32E-SLI/1302) and Q-fan does nothing. I tried setting target temp to max but still no change.
http://world3.net

PopCorn
Posts: 346
Joined: Tue Dec 12, 2006 5:09 pm
Location: U.S.A. Massuchusetts...... *Folding For SPCR*
Contact:

Post by PopCorn » Thu Dec 13, 2007 2:36 pm

eh it isnnt even great, and i dont even use it, i have 2 fans in my system one 200mm fan running a 800rpmm and a 120mm running at about 900rpm
And with that being said I have always been a bit proud of my 1337 computer sk1llz

bp
Posts: 19
Joined: Tue Dec 04, 2007 1:55 am

Post by bp » Fri Dec 14, 2007 5:16 am

Hi MoJo,

Have you applied changed (save BIOS and reboot) to check it doesn't work (my changes doesn't apply realtime in the BIOS, only affect the result after reboot) ?

Are you sure the fan is connected to the motherboard, on a controllable fan pin ? (I can only control speed on 2 of my 3 fan connectors : chassis & cpu, not on the power fan).

Can you read/monitor in the BIOS the speed of the fan ?

best regards

MoJo
Posts: 773
Joined: Mon Jan 13, 2003 9:20 am
Location: UK

Post by MoJo » Fri Dec 14, 2007 6:27 am

bp, I did do that, yes. I don't think it's a problem with Qfan itself though, but rather the temperature sensor on the mobo.

I have a QX6700. When Coretemp says one core has hit 67C, the mobo CPU temp sensor says 40C. I think Qfan is reading from the mobo sensor so it never changes the fan speed. It always seems to be on full anyway, and both BIOS and the Asus software allow you to set with Qfan or 60-100% speed, which has no effect.

The chassis and optional fan headers can be controlled manually and they work, just not the CPU one.
http://world3.net

Post Reply